QoS - LLQ (Low Latencey Queuing)

 

LLQ (Low Latencey Queuing)

LLQ は Priority Queuing と CBWFQ の 2 つの方式を併せた
キューイング方式
です。
LLQ は CBWFQ の方式に、1 つのクラスに対して PQ のような
絶対優先のクラスを作ることが可能です。

1 つ以上のクラスを絶対優先にすることも可能です。

音声など遅延を極力回避したい通信に対して、
絶対優先のクラスを割り当てます。

動作イメージは以下のような感じ。

 

クラスの割り当て

 

絶対優先のクラスは PQ(FIFO)で動作し、その他のクラスは
WFQ として動作
します。
(複数の絶対優先クラスが存在する場合は、1 つの PQ として動作します。)

パケットの処理は、まずキューの中に「PQ のパケットがあるか?」を
確認し、あれば PQ のパケットを処理します。
なければ残りのキュー間で WFQ の動作で処理をしていきます。

ここで PQ の動作を思い出してください。

PQ は、優先度の高いキューからパケットを処理していき、
パケットが無くなると次のキューのパケットを処理するという
動作を行います。

そのため、high キューに常にパケットが存在している場合、
high のパケットばかり処理してしまい、medium 以下のキューを
処理してくれません。

LLQ においても、PQ のパケットが大量に存在していた場合、
PQ のパケットばかりを処理してしまい、その他の WFQ のパケットを
処理してくれないという問題があります。

そこで、LLQ ではその問題を回避するために、絶対優先のクラスに
「輻輳時の最大帯域」を指定することが出来ます。

トラフィックが輻輳しているときは、指定した帯域幅以下に抑えることで、
WFQ のパケットの処理も行わせることが出来ます。

もちろん、輻輳が発生していない場合は、帯域制限されることはありません。

 

LLQ の設定

LLQ の設定は、基本的には CBWFQ と同じですので、詳細は以下 URL を
参照ください。

CBWFQ

絶対優先にしたいクラスに対して、以下の設定を追加することで、
そのクラスが絶対優先となります。

  • 絶対優先クラスを帯域幅で設定
    router(config-pmap-c)# priority [value] (burst)
  • 絶対優先クラスをパーセントで設定
    router(config-pmap-c)# priority percent [percent] (burst)

LLQ の設定例

では、設定例を見てみましょう。


class-map match-all CL-A
matchdscp 43
class-map match-all CL-B
match access-group 110
class-map match-any CL-C
matchprecedence 2
match protocol ftp
!
policy-map TEST
class CL-A
Priority 128
class CL-B
bandwidth percent 40
class CL-C
bandwidth percent 5
class class-default
queue-limit 128 packets
!
interface FastEthernet0/0
ip address 157.2.170.149 255.255.255.0
service-policy output TEST
!
access-list 110 permit ip any 10.1.1.0 0.0.0.255

 

LLQ の確認コマンド

設定の確認は「show policy-map interface」コマンドで実施します。


RT1#show policy-map interface fastEthernet 0/0
 FastEthernet0/0

 Service-policy output: TEST

 queue stats for all priority classes:
 Queueing
 queue limit 64 packets
 (queue depth/total drops/no-buffer drops) 0/0/0
 (pkts output/bytes output) 0/0

 Class-map: CL-A (match-all)
 0 packets, 0 bytes
 5 minute offered rate 0000 bps, drop rate 0000 bps
 Match:dscp 43
 Priority: 128 kbps, burst bytes 3200, b/w exceed drops: 0


 Class-map: CL-B (match-all)
 0 packets, 0 bytes
 5 minute offered rate 0000 bps, drop rate 0000 bps
 Match: access-group 110
 Queueing
 queue limit 64 packets
 (queue depth/total drops/no-buffer drops) 0/0/0
 (pkts output/bytes output) 0/0
 bandwidth 40% (40000 kbps)

 Class-map: CL-C (match-any)
 0 packets, 0 bytes
 5 minute offered rate 0000 bps, drop rate 0000 bps
 Match:precedence 2
 0 packets, 0 bytes
 5 minute rate 0 bps
 Match: protocol ftp
 0 packets, 0 bytes
 5 minute rate 0 bps
 Queueing
 queue limit 64 packets
 (queue depth/total drops/no-buffer drops) 0/0/0
 (pkts output/bytes output) 0/0
 bandwidth 5% (5000 kbps)

 Class-map: class-default (match-any)
 108 packets, 11104 bytes
 5 minute offered rate 0000 bps, drop rate 0000 bps
 Match: any
 108 packets, 11104 bytes
 5 minute rate 0 bps

 queue limit 128 packets
 (queue depth/total drops/no-buffer drops) 0/0/0
 (pkts output/bytes output) 110/11530

 

おすすめ記事

関連記事

メールマガジン

ネットワ-ク初心者のみなさま。
ネットワークの基礎知識を疎かにすることは
大変危険です!!

「初心者にも理解できるネットワーク技術」

これを読めばネットワークの基礎が分かる!!
ネットワーク関連の仕事に就きたいとお考えの学生の方や、ネットワークに興味があって転職を考えている社会人の方、まずは登録してみてください。

もちろん無料です!!

↓メールマガジン購読はこちら↓

メールアドレス: