ルーティング・OSPF -OSPF エリア-


OSPF:ネットワークタイプ

OSPFには大きく分けると4つのNetworkTypeに分けることが出来ます。

Network Type DR/BDRの選出 代表的なNetwork 説明
Broadcast multi-access あり Ethernet 全てのルータは同じサブネットにあり、隣接関係は自動で行われる。
Hello Timer: 10 seconds 、 Dead interval: 40 seconds 、 Wait interval: 40 seconds
non-broadcast multi-access あり Frame Relay 全てのルータは同じサブネットにあり、隣接関係は手動で行う必要がある
Hello Timer: 30 seconds 、 Dead interval: 120 seconds 、 Wait interval: 120 seconds
point-to-multipoint なし Frame Relay 全てのルータは同じサブネットにあり、隣接関係は自動で行われる。
マルチアクセス環境ではなくポイントツーポイントの集合とみなすのでDRとBDRの選出はない。
Hello Timer: 30 seconds 、 Dead interval: 120 seconds 、 Wait interval: 120 seconds
point-to-point なし 専用線 各Point-To-Pointリンク毎にサブネットが必要。
Hello Timer: 10 seconds 、 Dead interval: 40 seconds 、 Wait interval: 40 seconds

 

OSPF:NBMAネットワークでの問題点

NBMA(non-broadcast multi-access)Networkの場合、BroadcastやMulticastを送ることが出来ないため、Multicastを使用するHelloPacketは送出することが出来ない。
そこでNBMAの場合は手動でNeighborを定義しUnicastでHelloPacketを送信する。

Router(config-router)#neioghbor ip address

この、手動でNeighborコマンドを設定することを回避する手段として以下の方法があります。

1.point-to-point subinterface
subinterfaceは、interfaceを論理的に定義する方法です。同じ物理interfaceを複数の論理interfaceに分割でき、各subinterfaceをpoint-to-pointに定義できます。この方法により、OSPFではNBMA上のスプリット ホライズンが原因で生じる問題を対処することも可能。

【設定例】
interface Serial 0
no ip address
encapsulation frame-relay

interface Serial0.1 point-to-point
ip address 128.213.63.6 255.255.252.0
frame-relay interface-dlci 20

interface Serial0.2 point-to-point
ip address 128.213.64.6 255.255.252.0
frame-relay interface-dlci 30

router ospf 10
network 128.213.0.0 0.0.255.255 area 1

2.interface network type の変更
OSPF InterfaceのNetworkTypeを変更することにより対処する方法です。

ip ospf network {broadcast | non-broadcast | point-to-multipoint}

ただし、NBMA NetworkでBroadcast Networkを使用する場合は、DRは全てのRouterと物理的に接続されていなければならない。

 

OSPF マルチエリア

ネットワークが大規模になってくると、様々な弊害が発生する。

  • SPFアルゴリズムの計算頻度が高くなり大量のメモリを消費する。
  • ネットワークに流れるLSUが増える。

この問題を解決するためには、LSUが届く範囲を分割する(エリアの分割)をすることにより解決する。
リンクのどこかが変更されると、変更内容がエリア内の全てのルータに伝達されますが他のエリアには伝達されません。

(1)OSPF Single AREA

(2)OPSF Multi AREA

OSPFルータは4つに分類され、それぞれ役割が異なる。

該当ルータ ルータタイプ 説明
RTA、RTB
RTG、RTH
Internal Router (内部ルータ) 全てのインターフェースが同じエリア内にあるルータ。
エリア内部のアップデートと、エリア外の集約アップデートを受け取る。
RTC、RTD
RTE、RTF
Backbone Router (バックボーンルータ) 最低1つのインターフェースがバックボーンエリア内にあるルータ。
RTC、RTF Area Border Router :ABR(エリア境界ルータ) 複数のエリアに接続されたインターフェースをもつルータ。複数のリンクステートデーターベース(LSDB)が保持される。LSDBはバックボーンも含めて、接続したエリアごとに1つずつ保持される。
エリア外のアップデートを集約してエリア内に送る。
RTE Autonomous System Border Router :ASBR(自律システム境界ルータ) 非OSPFネットワーク(RIPなど)との境界ルータ。
AS外の経路情報を再配送してAS内に伝える。

 

OSPF:LSA(Link-state advertisements)Type

Type Name 説明 送信するルータ
ルータリンク エリア内のルータの各インタフェース、IPアドレス、および隣接ルータの情報が伝達されます。
エリア内でのみ伝達される。
全てのルータ
ネットワークリンク エリア内のルータのIDとともにBroadcast NetworkやNBMA NetworkなどのNetwork情報が伝達されます。
エリア内でのみ伝達される。
DR
ネットワークサマリリンク エリア間のNetwork Addressに関する情報。宛先NetworkのIPアドレスが設定されます。
AS内の他のABRへ伝達される。ただし完全スタブエリアには伝達されない。
ABR
ASBRサマリリンク ASBR(自律システム境界ルータ)のルータIDを伝達します。
AS内の他のABRへ伝達される。ただし完全スタブエリアには伝達されない。
ABR
ASエクスターナル(外部)リンク エクスターナル(外部)ルートのサマリ情報伝達します。
AS全体に伝達される。ただし完全スタブエリア、スタブエリア、NEESには伝達されない。
ASBR
グループメンバLSA(MOSPF) MOSPFによりMulticastのグループメンバの場所を伝達します。
NSSA(Not so stubby area:準スタブエリア)LSA NSSAエリアにおいて、限られた外部情報を取り込むために使用します。
NSSA内でのみ伝達される。
エクスターナル(外部)属性LSA iBGPの代わりにOSPFのRoutingDomainを経由してBGPパスの情報を伝達します。

 

OSPF エリアタイプ

エリアタイプ 説明
標準エリア 自エリア内の経路、自律システム内の他のOSPFエリアへの経路、および外部経路を認識。
LSA Typeは全てのType(1~5)を使用可能。
バックボーンエリア 複数のエリアを相互接続する中心となるエリア。他のエリアへの通信は常にバックボーンエリアを通らなければならない。(バックボーンエリアを通過しないで他エリアへ通信させたい場合は仮想リンクを使用する。)バックボーンエリアは常にarea0である。LSA Typeは全てのType(1~5)を使用可能。
スタブ(Stub)エリア LSA Type1,2,3のみ伝達し、エクスターナルLSAは伝達されないためASBRを設置することができない。スタブエリアのABRは、このエリア内にデフォルトルートが送信される。
スタブエリアを通過するような仮想リンクを設定することはできない。
完全スタブ(Totally Stub)エリア LSA Type1,2のみ伝達し、すべてのNetworkはサマライズされ、エリア内にデフォルトルートが送信される。学習できる経路はエリア内の経路とデフォルトルートのみ。
Ciscoが提唱した概念。他メーカーではエクスターン(extern)と呼ぶ。
準スタブ(Not so stubby)エリア スタブエリアの機能拡張版。基本的にスタブエリアの機能を踏襲しているが、新たにLSA Type 7を使用する。NSSAのASBRは外部経路をLSA Type 7に変換してOSPFエリアに伝達し、NSSAのABRにてLSA Type 5に変換され伝達されていく。
こうすることにより、外部経路情報を一方向にフィルタリングすることが可能。つまり、外部経路はNSSAを通してOSPFエリア内に伝達されるが、逆にOSPFエリア内の経路情報をNSSAを通して外部ネットワークに伝達することは出来ない。

 

OSPF 各エリアの特徴


  ※クリックすると大きな画像で見れます。

 

おすすめ記事

関連記事

メールマガジン

ネットワ-ク初心者のみなさま。
ネットワークの基礎知識を疎かにすることは
大変危険です!!

「初心者にも理解できるネットワーク技術」

これを読めばネットワークの基礎が分かる!!
ネットワーク関連の仕事に就きたいとお考えの学生の方や、ネットワークに興味があって転職を考えている社会人の方、まずは登録してみてください。

もちろん無料です!!

↓メールマガジン購読はこちら↓

メールアドレス:

検索

特集

初心者のためのciscoルータの管理

目指せPMP

▼ ネットワークエンジニアにおすすめのサイトはこちら ▼


著書

図解入門 よくわかる最新ネットワーク技術の基本と仕組み

初心者のためのCiscoルータ運用ガイド: 最速でCiscoルータを理解するための解説書

目指せPMP PMBOK第5版対応: 最速でPMPに合格するための解説書

見てわかるTCP/IP

おすすめ記事

カテゴリ

ブログ最新記事