Ciscoルータを管理する時によく使うコマンド(1)

ネットワークの運用者はルータの設定を行うよりも、状況を確認することの方が多いのが現実です。

「あれれ?どうもルータの挙動がおかしいな?」
「ふんがぁ!!通信が出来ないよぉ!!」

そんな時には、ルータで何が起こっているのかを、様々なコマンドを使って確かめていきます。今回はネットワーク管理者が運用する上で、使用頻度の高い確認コマンドをご紹介します。

設定の保存

ルータの設定を行っただけでは、コンフィグは RAM にしか保存されないため、ルータを再起動してしますと設定が元に戻ってしまいます。

そのため、設定後は保存しなければいけません。設定を保存するコマンドは以下の通りです。

Router#copy running-config startup-config

ここで一点注意しておかなければいけないことがあります。
たとえば設定を保存するコマンドを以下のように間違えて入力してしまった場合、

Router#copy running statup

このように通常「startup」と入力するところを、「statup」と間違えたスペルで実行してしまうと、保存先がNVRAMではなくフラッシュメモリに保存することになってしまいます。

フラッシュメモリにはIOSが格納されておりますから、IOSを削除するかどうかを聞いてきます。
メッセージをろくに読まずにリターンキーを連打しようものなら、フラッシュメモリ内のIOSは削除されてしまいますので注意してください。

Router#copy running-config statup
Destination filename [statup]? 
Erase flash: before copying? [confirm]
#ここでリターンキーを押そうモノならIOSが消えてしまいます。

設定の確認

すでに何度もご紹介しているコマンドですね。
現状の設定がどうなっているのかを確認するための、基本中の基本のコマンドですね。

  • 現在動作している設定を表示
    Router#show running-config
  • RAMに保存されていて、起動時に読み込まれる設定を表示
    Router#show startup-config

コマンド実行結果

Router#show running-config
Building configuration...

Current configuration : 1372 bytes
!
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
license udi pid CISCO892-K9 sn FHK1440765Y
!
!
vtp mode transparent
!
redundancy
!
!
!
!
!
! 
!
!
!
!
!
!
!
!
interface BRI0
 no ip address
 encapsulation hdlc
 shutdown
 isdn termination multidrop
!
interface FastEthernet0
 no ip address
!
interface FastEthernet1
 no ip address
!
interface FastEthernet2
 no ip address
!
interface FastEthernet3
 no ip address
!
interface FastEthernet4
 no ip address
!
interface FastEthernet5
 no ip address
!
interface FastEthernet6
 no ip address
!
interface FastEthernet7
 no ip address
!
interface FastEthernet8
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface GigabitEthernet0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Vlan1
 no ip address
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
!
!
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
 login
 transport input all
!
!
end

バージョンの確認

IOSのバージョンを確認するコマンドも基本的なコマンドですが重要です。

Router#show version

コマンド実行結果

Cisco IOS Software, C890 Software (C890-UNIVERSALK9-M), Version 15.3(3)M3, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2014 by Cisco Systems, Inc.
Compiled Wed 28-May-14 07:56 by prod_rel_team

ROM: System Bootstrap, Version 12.4(22r)YB5, RELEASE SOFTWARE (fc1)

Router uptime is 16 minutes
System returned to ROM by reload at 11:49:45 UTC Thu Mar 26 2015
System image file is "flash:c890-universalk9-mz.153-3.M3.bin"
Last reload type: Normal Reload
Last reload reason: Reload Command



This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 892 (MPC8300) processor (revision 1.0) with 747520K/38912K bytes of memory.
Processor board ID xxxxxxxxxxx

9 FastEthernet interfaces
1 Gigabit Ethernet interface
1 ISDN Basic Rate interface
1 Virtual Private Network (VPN) Module
256K bytes of non-volatile configuration memory.
250880K bytes of ATA CompactFlash (Read/Write)


License Info:

License UDI:

-------------------------------------------------
Device#   PID           SN
-------------------------------------------------
*0        CISCO892-K9           xxxxxxxxxxx     



License Information for 'c890'
    License Level: advipservices   Type: Permanent
    Next reboot license Level: advipservices


Configuration register is 0x2102

show versionコマンドはバージョンを確認する以外にも、現状のメモリサイズも確認することが出来ます。

IOSを新しいバージョンに入れ替えたい時は必ずこのメモリサイズを確認しておきましょう。

IOSによって必要なメモリ量が変わってきますので、アップグレードしたとたん起動しなくなってしまうこともあり得ます。

その他にもルータが起動してから経過した時間も確認することが出来ます。
障害が発生したときにこの時間を確認して、ルータが再起動したかどうかを確認することが出来ます。

おすすめ記事

  • 【特集】 いまさら聞けないIT契約書のはなし【第4回 契約の種類(2)】
  • 【特集】 進化する脅威にどう立ち向かうか【最終回】
  • 【特集】 災害復旧、事業継続計画(BCP)などの対策状況(2018年)・後編
  • 【特集】 地震や台風から情報資産を守る救世主・データセンター活用の今
  • 【特集】 「固定電話も、ムダ残業もやめた」徹底した"富士通流"働き方改革
  • 関連記事

    メールマガジン

    ネットワ-ク初心者のみなさま。
    ネットワークの基礎知識を疎かにすることは
    大変危険です!!

    「初心者にも理解できるネットワーク技術」

    これを読めばネットワークの基礎が分かる!!
    ネットワーク関連の仕事に就きたいとお考えの学生の方や、ネットワークに興味があって転職を考えている社会人の方、まずは登録してみてください。

    もちろん無料です!!

    ↓メールマガジン購読はこちら↓

    メールアドレス:

    検索

    特集

    初心者のためのciscoルータの管理

    目指せPMP


    著書

    図解入門 よくわかる最新ネットワーク技術の基本と仕組み

    初心者のためのCiscoルータ運用ガイド: 最速でCiscoルータを理解するための解説書

    目指せPMP PMBOK第5版対応: 最速でPMPに合格するための解説書

    見てわかるTCP/IP

    おすすめ記事

    カテゴリ

    ブログ最新記事