EIGRP -経路集約-


EIGRP:集約

EIGRP には、自動集約と手動集約の、2 つの集約形式があります。


EIGRP:自動集約

EIGRPの自動集約はメジャーネットワークの境界のみで経路集約を行う。

上図の場合、メジャーネットワークの境界であるRouterBは172.16.0.0/16だけをRouterAにアドバダイズします。
RouterBでshow ip route 172.16.0.0コマンドで確認すると、

#show ip route 172.16.0.0
Routing entry for 172.16.0.0/16, 5 known subnets
Attached (2 connections)
Variably subnetted with 2 masks
Redistributing via eigrp 100

C 172.16.10.0/24 is directly connected, Serial1
C 172.16.20.0/24 is directly connected, Serial2
D 172.16.1.0/24 [90/10537472] via 172.16.10.2, 01:36:44, Serial1
D 172.16.0.0/16 is a summary, 01:36:45, Null0
D 172.16.2.0/24 [90/10537472] via 172.16.20.2, 01:36:44, Serial2

となり、集約アドレス172.16.0.0がnull0としてRoutingTableに作成されます。
(172.16.100.1といった存在しないアドレスが送られてきた場合のRoutingLoopを回避するため)

自動集約を停止するにはRouterBのeigrp設定内にno auto-summaryを設定する。

※自動集約の例外について
例外として外部ルート(RIP,OSPF,Static,redistribute connected等)で取り込んだRoutingは自動集約しません。

 

EIGRP:手動集約

手動集約を行うと上図のようにRouterBでCIDRブロックに集約も出来ます。
設定はUpDateを送出するInterfaceに、ip summary-address eigrp を設定します。

interface Serial0
ip address 192.168.1.2 255.255.255.0
ip summary-address eigrp 100 172.16.0.0 255.255.252.0

 

EIGRP:Defoult Routing

EIGRPにDefoultRouteを注入する方法は2種類。

StaticRouteを再配送
設定例
ip route 0.0.0.0 0.0.0.0 172.16.1.1

router eigrp 100
redistribute static

0.0.0.0/0への手動集約
設定例
router eigrp 100
network 10.0.0.0

interface serial 0
ip address 10.1.1.1
ip summary-address eigrp 100 0.0.0.0 0.0.0.0

 

EIGRP:Load Balancing

Eigrpの等コスト及び不等コストのload balancingに対応しています。(Defoultでは4つまで。max-pathsコマンドを使用すると最大6つまで使用できます)

Souce Neighbor Feasible Distance Advertised Distance
172.16.1.1 B 40 25 サクセサ
C 40 25 サクセサ
D 55 35 フィジブル・サクセサ
E 100 50

上図のように等コストがある場合、Defoultにより宛先BとCでload balancingを行います。

宛先Dにもload balancingさせる場合はvarianceコマンドを使用します。
このvarianceコマンドの値によってload balancingを制御します。
不等コストパスに追加されるかどうかは以下のように決定されます。

サクセサのFD × variance値 > フィジブル・サクセサになり得るパスのFD

上図の例だと、varianceの値を"2"とした場合、サクセサのFDは"40"なので40 × 2 = 80以下のパスが候補となり、その中でフィジブル・サクセサとなり得るパスなので宛先Dのパスがload balancingの対象になる。

パスごとのトラヒック配分は以下の式で決定されます。

最大メトリック / 対象パス

で得た値を小数点以下を切り捨てた値がトラヒック配分値となります。
この例ではトラヒック配分値は次のようになります。

宛先B及びCのパスは 100/40 = 2
宛先Dのパスは 100/55 = 1

となり、最初の2Packetは宛先Bのパスで、次の2Packetは宛先Cのパスで、次の1Packetを宛先Dのパスで送信します。

 

おすすめ記事

  • 【特集】 いまさら聞けないIT契約書のはなし【第4回 契約の種類(2)】
  • 【特集】 進化する脅威にどう立ち向かうか【最終回】
  • 【特集】 災害復旧、事業継続計画(BCP)などの対策状況(2018年)・後編
  • 【特集】 地震や台風から情報資産を守る救世主・データセンター活用の今
  • 【特集】 「固定電話も、ムダ残業もやめた」徹底した"富士通流"働き方改革
  • 関連記事

    メールマガジン

    ネットワ-ク初心者のみなさま。
    ネットワークの基礎知識を疎かにすることは
    大変危険です!!

    「初心者にも理解できるネットワーク技術」

    これを読めばネットワークの基礎が分かる!!
    ネットワーク関連の仕事に就きたいとお考えの学生の方や、ネットワークに興味があって転職を考えている社会人の方、まずは登録してみてください。

    もちろん無料です!!

    ↓メールマガジン購読はこちら↓

    メールアドレス:

    検索

    特集

    初心者のためのciscoルータの管理

    目指せPMP


    著書

    図解入門 よくわかる最新ネットワーク技術の基本と仕組み

    初心者のためのCiscoルータ運用ガイド: 最速でCiscoルータを理解するための解説書

    目指せPMP PMBOK第5版対応: 最速でPMPに合格するための解説書

    見てわかるTCP/IP

    おすすめ記事

    カテゴリ

    ブログ最新記事