Ciscoルータのコンフィグの考え方

今回はルータの設定に関する基本的な考え方や設定の確認方法などについて書いていきます。実際に設定を行う前に、概念を理解することはとても大事なことです。

ルータのConfigファイルの考え方

実際に設定を始める前に、Ciscoルータの設定ファイルの考え方について解説していきます。ルータは起動時にNVRAMに格納されている設定ファイルを読み込みます。
このNVRAMに格納されている設定ファイルのことを「startup-config」と言います。起動時にこのstartup-configをRAMに読み込みます。

RAM上に読み込まれた設定ファイルのことを「running-config」と言います。このようにCiscoルータは保存されている設定ファイルと、実際に使用している設定ファイルの2種類が存在します。

ルータの設定を変更した場合、その内容は「running-config」に反映されます。

running-configはRAM上に存在しますから、このままルータを再起動してしまうと、「起動した後の設定ファイルには変更した設定は反映されません。」

つまりCiscoルータの設定を変更したら「startup-config」へも反映させる必要があります。この行為を忘れてしまうとえらい目にあいますから、しっかり覚えておきましょう。

ここまでの説明をまとめますと、下図のようになります。

設定を確認してみよう

さて実際に設定に入る前に、現状の設定を確認してみましょう。まず現状動作している設定、「running-config」を確認してみます。確認するコマンドは“特権モード”にて

	router#show running-config

と入力します。

コマンド実行結果

    router#show running-config
	Current configuration : 1372 bytes
	!
	version 15.3
	service timestamps debug datetime msec
	service timestamps log datetime msec
	no service password-encryption
	!
	hostname Router
	!
	boot-start-marker
	boot-end-marker
	!
	!
	!
	no aaa new-model
	!
	ip cef
	no ipv6 cef
	!
	multilink bundle-name authenticated
	!
	license udi pid CISCO892-K9 sn FHK1440765Y
	!
	!
	vtp mode transparent
	!
	redundancy
	!
	interface BRI0
	 no ip address
	 encapsulation hdlc
	 shutdown
	 isdn termination multidrop
	!
	interface FastEthernet0
	 no ip address
	!
	interface FastEthernet1
	 no ip address
	!
	interface FastEthernet2
	 no ip address
	!
	interface FastEthernet3
	 no ip address
	!
	interface FastEthernet4
	 no ip address
	!
	interface FastEthernet5
	 no ip address
	!
	interface FastEthernet6
	 no ip address
	!
	interface FastEthernet7
	 no ip address
	!
	interface FastEthernet8
	 no ip address
	 shutdown
	 duplex auto
	 speed auto
	!
	interface GigabitEthernet0
	 no ip address
	 shutdown
	 duplex auto
	 speed auto
	!
	interface Vlan1
	 no ip address
	!
	ip forward-protocol nd
	no ip http server
	no ip http secure-server
	!
	!
	control-plane
	!
	mgcp behavior rsip-range tgcp-only
	mgcp behavior comedia-role none
	mgcp behavior comedia-check-media-src disable
	mgcp behavior comedia-sdp-force disable
	!
	mgcp profile default
	!
	!
	line con 0
	line aux 0
	line vty 0 4
	 login
	 transport input all
	!
	!
	end

上の例は設定がされていない初期状態のConfigです。

つづいて、NVRAMに格納されている設定、「startup-config」を確認してみましょう。
コマンドは、“特権モード”にて

	router#show startup-config

を入力します。

	Router#show startup-config
	Building configuration...
	
	!
	version 15.3
	service timestamps debug datetime msec
	service timestamps log datetime msec
	no service password-encryption
	!
	hostname Router
	!
	boot-start-marker
	boot-end-marker
	
	~以下省略~

startup-configも初期状態ですので、running-configと同じ設定が表示されます。

runnning-configをstartup-configへ反映しましょう

ルータの設定を変更したら、必ず実行しないといけない作業がこの作業です。

設定の変更は、RAM上のrunning-configにしか反映されません。
そのためrunning-configの内容を、startup-configへコピーする必要があります。
この作業を実施しない場合、ルータが再起動したときに設定変更前の設定で起動してしまいます。
コマンドは“特権モード”にて、

	router#copy running-config startup-config

と入力します。

	Router#copy running-config startup-config
	Destination filename startup-config? 「リターンキー」
	Building configuration...
	OK

ここで、

	Destination filename \[startup-config]?

と聞いてきます。
この意味は

コピー先のファイル名はstartup-configでいいか?

という意味です。

このままで良いので、そのまま「リターンキー」を押せばOKです。

これでNVRAMに設定をコピーしましたから、ルータを再起動しても、変更後のconfigで立ち上がってきます。

設定を変更した後は、必ず保存する習慣を身につけておきましょう。
「そんなの当然だろう?」なんて思うかもしれませんが意外に忘れがちですので、気をつけましょう。

configはしっかりとバックアップしましょう

Ciscoルータに設定したconfigファイルはとても大事です。ルータ障害時のリストアや障害切り分け時など、さまざまな場面でconfigファイルをチェックすることが多いです。

設定変更を行ったらstartup-configへのコピーはもちろん、他の媒体へも必ずバックアップを取っておきましょう。

configのバックアップといっても、テキストファイルですから、「show running-config」か「show startup-config」の表示結果をテキストファイルで保存しておくだけです。

Teratermの場合、「ファイル」-「ログ」を実行すると、保存先を聞いてきますから、ファイル名を指定します。

これでこれ以降Teraterm上に表示される情報を全てログとして保存してくれます。

後はログの設定をした後に「show startup-config」を実行すれば、そのままログとして保存されます。

configを表示させた後にログの取得を終了します。
下のウインドウの「Close」ボタンを押せばログの取得を終了させることが出来ます。

実際にログが保存されているか確認してみてください。

moreが邪魔だぁ~

ここで保存されたログに「–more–」という文字列も保存された方、いますか?いますね?

この–more–は表示が一画面に収まらない場合に、まだ続きがあるよという意味でターミナル上に表示されるものです。バックアップする設定ファイルには必要のない文字列です。

ログに保存した後に、テキストエディタで置換を使って消してももちろんよいのですが、どうせならログに保存するときに–more–が保存されないようにしたいですね。

特権モードにて「terminal length 0」というコマンドを実行した後に、「show startup-config」コマンドで設定を表示させてみてください。

	Router#terminal length 0
	Router#show startup-config

上記コマンドを入力することで、startup-configを結果が途中で止まらずに表示されるはずです。

この「terminal length」というコマンドはターミナルの画面に表示させる行数を指定できるコマンドです。

「terminal length 0」とは表示させる行数が0、つまりすべてを表示させるという意味です。

試しに「terminal length 24」と設定してもう一度startup-configを実行してみましょう。

	Router#terminal length 24
	Router#show startup-config

–more–が24行おきに表示されるはずです。

ちなみにデフォルトの値は「24」で、この値を変更したとしても一度ログアウトしてから再度ログインするとデフォルトの24に戻っています。

おすすめ記事

関連記事

メールマガジン

ネットワ-ク初心者のみなさま。
ネットワークの基礎知識を疎かにすることは
大変危険です!!

「初心者にも理解できるネットワーク技術」

これを読めばネットワークの基礎が分かる!!
ネットワーク関連の仕事に就きたいとお考えの学生の方や、ネットワークに興味があって転職を考えている社会人の方、まずは登録してみてください。

もちろん無料です!!

↓メールマガジン購読はこちら↓

メールアドレス:

検索

特集

初心者のためのciscoルータの管理

目指せPMP

▼ ネットワークエンジニアにおすすめのサイトはこちら ▼


著書

図解入門 よくわかる最新ネットワーク技術の基本と仕組み

初心者のためのCiscoルータ運用ガイド: 最速でCiscoルータを理解するための解説書

目指せPMP PMBOK第5版対応: 最速でPMPに合格するための解説書

見てわかるTCP/IP

おすすめ記事

カテゴリ

ブログ最新記事