Cisco IOS の小技(2)

 

show コマンド実行中に文字列検索

show コマンドを実行中に --More-- が表示されている状態で、「/」を
入力した後に、検索したい文字列を入力しリターンキーを押すと、
その文字列が含まれている箇所までジャンプしてくれます。

説明だと分かりづらいので実際にやってみましょう。

まずは、「show run」を実行します。


R1#show running-config
Building configuration...

Current configuration : 1095 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$7Mv3$GJ9H2d4MUB2IM8vmqAWym0
!
no aaa new-model
!
resource policy
!
!
--More--
      

ここで「/router ospf」と入力すると、


/router ospf
filtering...
router ospf 1
log-adjacency-changes
redistribute connected subnets
network 10.2.1.0 0.0.0.255 area 0
!
!
ip http server
no ip http secure-server
!
~省略~

このように「router ospf」を含む箇所までジャンプします。

 

設定中(コンフィグレーションモード)に show コマンドを確認したいとき

設定中(コンフィグレーションモード)に show run コマンドで設定を
確認したいとき
ってありますよね。
コンフィグレーションモードで「show run」を実行してもエラーに
なってしまします。

かといって、コンフィグレーションモードを抜けるのも面倒くさい。

そんな時に便利なコマンドが「do」コマンドです。

実際に実行したいコマンドの前に、「do」を付けて実行します。
show run コマンドを実行したい場合は。



Router(config)# do show run
      

これでコンフィグレーションモード中でも、「show run」結果を
確認することができます。

show run 以外の show コマンドはもちろん、Ping コマンドなども
使用可能です。

Router(config)# do ping 10.1.1.1

 

IP ドメインのルックアップを停止する

IOS 機器では、誤ったコマンドを実行してしまった場合に、
その文字列をホスト名として DNS サーバーへ名前解決をしてしまいます。

問い合わせの間、一切のコマンドを受け付けなくなってしまい、
非常に不快です。

この動作をさせないようにするには、以下の設定をします。


Router(config)#no ip domain-lookup

この動作がなぜデフォルトで無効になっていないのか不思議でならないです。

 

IOS からの Telnet タイムアウト時間の変更

通常 IOS 機器から、誤って存在しないアドレス宛別のノードへ
Telnet や SSH コマンドを実行した場合、30 秒間の Interval 後に
タイムアウト
になります。

「正直 30 秒も待ってられない」という方は、以下の設定を
しておきましょう。



ip tcp synwait-time [interval]
      

例えば、タイムアウトまでの時間を 5 秒にしたい場合、



Router(config)#ip tcp synwait-time 5
      

と設定すれば OK です。

 

コマンド入力中に、ログが出力されても再表示

コマンドを入力しているときに、ルータからのメッセージが表示されて、
コマンドが分断されてしまうことを防ぐコマンド
です。

デフォルトの場合、コマンドを入力しているときに、ルータからの
メッセージが表示されてると、以下のようにコマンドが分断されてしまい、
とても見づらくなってしまいます。


R1#show
01:26:04: %SYS-5-CONFIG_I: Configured from console by consolerun
      

上記の場合、「show run」と打とうとしたところ、「run」が
メッセージの後ろにいってしまいました。

そのままコマンドを続けても問題はないのですが、とても見づらい。

そんな時は、以下のコマンドを設定しましょう。


Switch(config-line)#logging synchronous

コンソール接続と Telnet 接続に適用する場合は、
以下のように設定します。


Switch(config)#line con 0
Switch(config-line)#logging synchronous
Switch(config-line)#line vty 0 15
Switch(config-line)#logging synchronous

この設定をすることで、コマンド入力中にルータからメッセージ割り込みが
発生しても、入力途中のコマンドを再表示してくれるようになります。

 

セクション毎に設定をデフォルト設定に戻す

例えば、「あるインタフェースの設定だけデフォルトに戻したい」とか、
「OSPF 設定をデフォルトに戻したい」なんてことがあるかもしれません。

そんな時に便利なコマンドが「default」コマンドです。

interface FastEthernet0/0 をデフォルト設定に戻したい場合は、



R1(config-if)#default int fa0/0

とすることでデフォルト設定に戻すことが出来ます。

実際にコマンド実行例を見てみましょう。

 

現在の設定を確認


R1(config-if)#do show run int fa0/0
Building configuration...

Current configuration : 102 bytes
!
interface FastEthernet0/0
description TEST
ip address 192.168.1.1 255.255.255.0
end
      

 

「default」コマンドを実行


R1(config-if)#default int fa0/0
Interface FastEthernet0/0 set to default configuration

 

インタフェース設定を確認してみます


R1(config)#do show run int fa0/0
Building configuration...

Current configuration : 61 bytes
!
interface FastEthernet0/0
no ip address
duplex half
end

以上のように設定していた「description」と「ip address」設定が
消えています。

 

description に「?」を使用する

あまり使用することが無いかもしれませんが、Interface に description を
設定する際に、文字列に「?」を使いたい
場合、普通に設定しようとすると、


Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#int
Router(config)#interface fa
Router(config)#interface fastEthernet 0/0
Router(config-if)#des
Router(config-if)#description cisco?
LINE    <cr>
Router(config-if)#description cisco
      

となり、設定が出来ません。

その場合は、「?」を入力する前に、「CTRL+V」を押してから入力します。



Router(config-if)#description cisco[CTRL+V]?
      

おすすめ記事

関連記事

メールマガジン

ネットワ-ク初心者のみなさま。
ネットワークの基礎知識を疎かにすることは
大変危険です!!

「初心者にも理解できるネットワーク技術」

これを読めばネットワークの基礎が分かる!!
ネットワーク関連の仕事に就きたいとお考えの学生の方や、ネットワークに興味があって転職を考えている社会人の方、まずは登録してみてください。

もちろん無料です!!

↓メールマガジン購読はこちら↓

メールアドレス: